Skip to content
CTI Academy Sponsor CTI Academy
MEDIUM · CVSS 6.9 CISA Known Exploited Vulnerability

CVE-2020-11023

JQuery Cross-Site Scripting (XSS) Vulnerability

JQuery JQuery

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

CVSS
6.9
MEDIUM
EPSS
84.9%
30-day exploitation
Ransomware groups
0
recorded exploiting
Published
29 Apr 2020
CWE-79

Exploitation status

CISA Known Exploited Vulnerabilities

Listed by CISA on 23 January 2025. US federal agencies were required to remediate it by 13 February 2025.

EPSS — exploitation probability

FIRST puts the probability of exploitation activity in the next 30 days at 84.9%, which is higher than 99.7% of all scored vulnerabilities. EPSS is a forecast of activity, not a measure of severity, and it is rescored daily.

CVSS vector

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N

Frequently asked questions

Is CVE-2020-11023 being exploited by ransomware groups?

No ransomware group in this database is currently recorded as exploiting CVE-2020-11023.

What does CVE-2020-11023 affect?

CVE-2020-11023 affects JQuery JQuery. In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

How severe is CVE-2020-11023?

CVE-2020-11023 is rated MEDIUM with a CVSS base score of 6.9. EPSS puts the probability of exploitation in the next 30 days at 84.9%, higher than 99.7% of all scored vulnerabilities. It is listed in the CISA Known Exploited Vulnerabilities catalog, with a federal remediation deadline of 13 February 2025.

How should organisations respond to CVE-2020-11023?

Apply the vendor patch for JQuery JQuery as the first priority, and treat any internet-facing instance as the most urgent. Because this vulnerability is associated with ransomware activity, also review whether the affected systems were reachable before patching, rather than assuming that patching alone closes the incident.