CVE-2021-41277
Metabase GeoJSON API Local File Inclusion Vulnerability
Metabase Metabase
Metabase is an open source data analytics platform. In affected versions a security issue has been discovered with the custom GeoJSON map (`admin->settings->maps->custom maps->add a map`) support and potential local file inclusion (including environment variables). URLs were not validated prior to being loaded. This issue is fixed in a new maintenance release (0.40.5 and 1.40.5), and any subsequent release after that. If you’re unable to upgrade immediately, you can mitigate this by including rules in your reverse proxy or load balancer or WAF to provide a validation filter before the application.
Exploitation status
CISA Known Exploited Vulnerabilities
Listed by CISA on 12 November 2024. US federal agencies were required to remediate it by 3 December 2024.
EPSS — exploitation probability
FIRST puts the probability of exploitation activity in the next 30 days at 97.2%, which is higher than 99.9% of all scored vulnerabilities. EPSS is a forecast of activity, not a measure of severity, and it is rescored daily.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
Frequently asked questions
Is CVE-2021-41277 being exploited by ransomware groups?
No ransomware group in this database is currently recorded as exploiting CVE-2021-41277.
What does CVE-2021-41277 affect?
CVE-2021-41277 affects Metabase Metabase. Metabase is an open source data analytics platform. In affected versions a security issue has been discovered with the custom GeoJSON map (`admin->settings->maps->custom maps->add a map`) support and potential local file inclusion (including environment variables). URLs were not validated prior to being loaded. This issue is fixed in a new maintenance release (0.40.5 and 1.40.5), and any subsequent release after that. If you’re unable to upgrade immediately, you can mitigate this by including rules in your reverse proxy or load balancer or WAF to provide a validation filter before the application.
How severe is CVE-2021-41277?
CVE-2021-41277 is rated CRITICAL with a CVSS base score of 10. EPSS puts the probability of exploitation in the next 30 days at 97.2%, higher than 99.9% of all scored vulnerabilities. It is listed in the CISA Known Exploited Vulnerabilities catalog, with a federal remediation deadline of 3 December 2024.
How should organisations respond to CVE-2021-41277?
Apply the vendor patch for Metabase Metabase as the first priority, and treat any internet-facing instance as the most urgent. Because this vulnerability is associated with ransomware activity, also review whether the affected systems were reachable before patching, rather than assuming that patching alone closes the incident.