CVE-2024-44308
Apple Multiple Products Code Execution Vulnerability
Apple Multiple Products
The issue was addressed with improved checks. This issue is fixed in Safari 18.1.1, iOS 17.7.2 and iPadOS 17.7.2, iOS 18.1.1 and iPadOS 18.1.1, macOS Sequoia 15.1.1, visionOS 2.1.1. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited on Intel-based Mac systems.
Exploitation status
CISA Known Exploited Vulnerabilities
Listed by CISA on 21 November 2024. US federal agencies were required to remediate it by 12 December 2024.
EPSS — exploitation probability
FIRST puts the probability of exploitation activity in the next 30 days at 9.9%, which is higher than 95.6% of all scored vulnerabilities. EPSS is a forecast of activity, not a measure of severity, and it is rescored daily.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Frequently asked questions
Is CVE-2024-44308 being exploited by ransomware groups?
No ransomware group in this database is currently recorded as exploiting CVE-2024-44308.
What does CVE-2024-44308 affect?
CVE-2024-44308 affects Apple Multiple Products. The issue was addressed with improved checks. This issue is fixed in Safari 18.1.1, iOS 17.7.2 and iPadOS 17.7.2, iOS 18.1.1 and iPadOS 18.1.1, macOS Sequoia 15.1.1, visionOS 2.1.1. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited on Intel-based Mac systems.
How severe is CVE-2024-44308?
CVE-2024-44308 is rated HIGH with a CVSS base score of 8.8. EPSS puts the probability of exploitation in the next 30 days at 9.9%, higher than 95.6% of all scored vulnerabilities. It is listed in the CISA Known Exploited Vulnerabilities catalog, with a federal remediation deadline of 12 December 2024.
How should organisations respond to CVE-2024-44308?
Apply the vendor patch for Apple Multiple Products as the first priority, and treat any internet-facing instance as the most urgent. Because this vulnerability is associated with ransomware activity, also review whether the affected systems were reachable before patching, rather than assuming that patching alone closes the incident.