Skip to content
CTI Academy Sponsor CTI Academy
CRITICAL · CVSS 10 CISA Known Exploited Vulnerability

CVE-2024-51567

CyberPanel Incorrect Default Permissions Vulnerability

CyberPersons CyberPanel

upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.

CVSS
10
CRITICAL
EPSS
84.4%
30-day exploitation
Ransomware groups
0
recorded exploiting
Published
29 Oct 2024
CWE-306

Exploitation status

CISA Known Exploited Vulnerabilities

Listed by CISA on 7 November 2024. US federal agencies were required to remediate it by 28 November 2024. CISA records this vulnerability as known to be used in ransomware campaigns.

EPSS — exploitation probability

FIRST puts the probability of exploitation activity in the next 30 days at 84.4%, which is higher than 99.7% of all scored vulnerabilities. EPSS is a forecast of activity, not a measure of severity, and it is rescored daily.

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Frequently asked questions

Is CVE-2024-51567 being exploited by ransomware groups?

No ransomware group in this database is currently recorded as exploiting CVE-2024-51567.

What does CVE-2024-51567 affect?

CVE-2024-51567 affects CyberPersons CyberPanel. upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.

How severe is CVE-2024-51567?

CVE-2024-51567 is rated CRITICAL with a CVSS base score of 10. EPSS puts the probability of exploitation in the next 30 days at 84.4%, higher than 99.7% of all scored vulnerabilities. It is listed in the CISA Known Exploited Vulnerabilities catalog, with a federal remediation deadline of 28 November 2024.

How should organisations respond to CVE-2024-51567?

Apply the vendor patch for CyberPersons CyberPanel as the first priority, and treat any internet-facing instance as the most urgent. Because this vulnerability is associated with ransomware activity, also review whether the affected systems were reachable before patching, rather than assuming that patching alone closes the incident.