Skip to content
CTI Academy Sponsor CTI Academy
HIGH · CVSS 8.2 CISA Known Exploited Vulnerability

CVE-2025-58360

OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability

OSGeo GeoServer

GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.

CVSS
8.2
HIGH
EPSS
61.2%
30-day exploitation
Ransomware groups
0
recorded exploiting
Published
25 Nov 2025
CWE-611

Exploitation status

CISA Known Exploited Vulnerabilities

Listed by CISA on 11 December 2025. US federal agencies were required to remediate it by 1 January 2026.

EPSS — exploitation probability

FIRST puts the probability of exploitation activity in the next 30 days at 61.2%, which is higher than 99.2% of all scored vulnerabilities. EPSS is a forecast of activity, not a measure of severity, and it is rescored daily.

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L

Frequently asked questions

Is CVE-2025-58360 being exploited by ransomware groups?

No ransomware group in this database is currently recorded as exploiting CVE-2025-58360.

What does CVE-2025-58360 affect?

CVE-2025-58360 affects OSGeo GeoServer. GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.

How severe is CVE-2025-58360?

CVE-2025-58360 is rated HIGH with a CVSS base score of 8.2. EPSS puts the probability of exploitation in the next 30 days at 61.2%, higher than 99.2% of all scored vulnerabilities. It is listed in the CISA Known Exploited Vulnerabilities catalog, with a federal remediation deadline of 1 January 2026.

How should organisations respond to CVE-2025-58360?

Apply the vendor patch for OSGeo GeoServer as the first priority, and treat any internet-facing instance as the most urgent. Because this vulnerability is associated with ransomware activity, also review whether the affected systems were reachable before patching, rather than assuming that patching alone closes the incident.