Skip to content
CTI Academy Sponsor CTI Academy
CRITICAL · CVSS 9.9 CISA Known Exploited Vulnerability

CVE-2025-68613

n8n Improper Control of Dynamically-Managed Code Resources Vulnerability

n8n n8n

n8n is an open source workflow automation platform. Versions starting with 0.211.0 and prior to 1.120.4, 1.121.1, and 1.122.0 contain a critical Remote Code Execution (RCE) vulnerability in their workflow expression evaluation system. Under certain conditions, expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations. This issue has been fixed in versions 1.120.4, 1.121.1, and 1.122.0. Users are strongly advised to upgrade to a patched version, which introduces additional safeguards to restrict expression evaluation. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only; and/or deploy n8n in a hardened environment with restrict

CVSS
9.9
CRITICAL
EPSS
99%
30-day exploitation
Ransomware groups
0
recorded exploiting
Published
19 Dec 2025
CWE-913

Exploitation status

CISA Known Exploited Vulnerabilities

Listed by CISA on 11 March 2026. US federal agencies were required to remediate it by 25 March 2026.

EPSS — exploitation probability

FIRST puts the probability of exploitation activity in the next 30 days at 99%, which is higher than 99.9% of all scored vulnerabilities. EPSS is a forecast of activity, not a measure of severity, and it is rescored daily.

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Frequently asked questions

Is CVE-2025-68613 being exploited by ransomware groups?

No ransomware group in this database is currently recorded as exploiting CVE-2025-68613.

What does CVE-2025-68613 affect?

CVE-2025-68613 affects n8n n8n. n8n is an open source workflow automation platform. Versions starting with 0.211.0 and prior to 1.120.4, 1.121.1, and 1.122.0 contain a critical Remote Code Execution (RCE) vulnerability in their workflow expression evaluation system. Under certain conditions, expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations. This issue has been fixed in versions 1.120.4, 1.121.1, and 1.122.0. Users are strongly advised to upgrade to a patched version, which introduces additional safeguards to restrict expression evaluation. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only; and/or deploy n8n in a hardened environment with restrict

How severe is CVE-2025-68613?

CVE-2025-68613 is rated CRITICAL with a CVSS base score of 9.9. EPSS puts the probability of exploitation in the next 30 days at 99%, higher than 99.9% of all scored vulnerabilities. It is listed in the CISA Known Exploited Vulnerabilities catalog, with a federal remediation deadline of 25 March 2026.

How should organisations respond to CVE-2025-68613?

Apply the vendor patch for n8n n8n as the first priority, and treat any internet-facing instance as the most urgent. Because this vulnerability is associated with ransomware activity, also review whether the affected systems were reachable before patching, rather than assuming that patching alone closes the incident.