CVE-2026-42208
BerriAI LiteLLM SQL Injection Vulnerability
BerriAI LiteLLM
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.
Ransomware groups exploiting CVE-2026-42208
The Gentlemen is a RaaS group that emerged in July–August 2025, rapidly claiming over 320 victims across 17+ countries by offering affiliates a 90% revenue share, deploying a Go-based locker against Windows, Linux, NAS, and BSD systems; a compromised C2 server
Exploitation is attributed to these groups across their recorded activity. It does not follow that every organisation they listed was reached through CVE-2026-42208 — the source data does not record an entry point per incident.
Exploitation status
CISA Known Exploited Vulnerabilities
Listed by CISA on 8 May 2026. US federal agencies were required to remediate it by 11 May 2026.
EPSS — exploitation probability
FIRST puts the probability of exploitation activity in the next 30 days at 89.4%, which is higher than 99.8% of all scored vulnerabilities. EPSS is a forecast of activity, not a measure of severity, and it is rescored daily.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Recent listings by these groups
Disclosures from the groups above, newest first.
Frequently asked questions
Is CVE-2026-42208 being exploited by ransomware groups?
Yes. CVE-2026-42208 is recorded as exploited by Thegentlemen. Between them these groups account for 1,156 victim disclosures in this database.
What does CVE-2026-42208 affect?
CVE-2026-42208 affects BerriAI LiteLLM. LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.
How severe is CVE-2026-42208?
CVE-2026-42208 is rated CRITICAL with a CVSS base score of 9.8. EPSS puts the probability of exploitation in the next 30 days at 89.4%, higher than 99.8% of all scored vulnerabilities. It is listed in the CISA Known Exploited Vulnerabilities catalog, with a federal remediation deadline of 11 May 2026.
How should organisations respond to CVE-2026-42208?
Apply the vendor patch for BerriAI LiteLLM as the first priority, and treat any internet-facing instance as the most urgent. Because this vulnerability is associated with ransomware activity, also review whether the affected systems were reachable before patching, rather than assuming that patching alone closes the incident.